Error
QuickBooks Online requires the currency of the transaction to match the currency of the vendor to calculate correctly.
Cause
The Currency on the purchase order does not match the currency of the Vendor in QuickBooks Online.
Resolution
Best Practice is to ensure the Vendor's Company Finance Profile in ConnectWise is the same as QuickBooks Online. To correct the issue, you will need to change the currency on the purchase order. Unfortunately this will require you to recreate it as the Currency is unable to be changed after it is initially saved.
1. Verify the Currency listed on the purchase order.
In ConnectWise PSA, navigate to Procurement > Purchase Orders > open the purchase order and verify the Currency highlighted in the screenshot below.
The Currency listed in the vendor profile needs to match both, in ConnectWise and QuickBooks Online. The purchase order will need to be recreated to match the currency listed in in the Vendors Company Finance Profile. Once these match, you should be able to batch to QuickBooks Online.