Error
Business validation error: Enter a transaction amount that is greater than 0
Cause
QuickBooks Online is presenting the error indicating the transaction amount must be greater than 0. We've identified this as an issue with progress billing with a down payment applied. This may be affecting all invoices with down payments applied. We have done extensive testing and are unable to determine the root cause of this error.
Work Around
In ConnectWise
- Remove the down payment applied to the invoice
- Close the Invoice
In Mobius
- Batch the invoice to QuickBooks Online
In QuickBooks Online
- Edit the invoice and apply the down payment
- Save and Close the invoice
In ConnectWise
- Unbatch the Invoice
- Set the status to New
- Apply the down payment
- Close the invoice
- Remove the Invoice from the Accounting Interface screen