Error
Encountered ConnectWise API Error: 400 Accounting Batch object is invalid
Causes
This error can be given for a number of reasons.
1. Batches are trying to run at the same time
Cause: Manual Batch and AutoSync Batch are trying to run at the same time
Resolution:
- Turn off AutoSync
- Batch invoices/expense/inventory
- Verify Completion
- Turn AutoSync back on
2. AutoSync or Manual batches are occurring too often for the amount of invoices waiting to be batched.
Cause: Auto sync is not finished batching the first batch and starts a new batch.
Resolution:
- Wait until all batches complete or fail
- Run a manual sync (optional)
- Set AutoSync time to the default 120 minutes
3. QuickBooks was unsuccessful in receiving access token
Cause: This can happen for a multitude of reasons.
Resolution:
- This is a known issue at this time
- This can cause AutoSync to disconnect.
- Verify AutoSync is still enabled.
4. Batch is too large
Cause: The batch is greater than 100 invoices, expenses, purchase orders, or payments
Resolution:
- AutoSync will break this into multiple batches of 100
- Please try submitting a smaller batch if a manual batch is needed.