Encountered ConnectWise API Error: 400 Accounting Batch object is invalid

Error

Encountered ConnectWise API Error: 400 Accounting Batch object is invalid

Causes

This error can be given for a number of reasons. 

1. Batches are trying to run at the same time

Cause: Manual Batch and AutoSync Batch are trying to run at the same time

Resolution:

  1. Turn off AutoSync 
  2. Batch invoices/expense/inventory
  3. Verify Completion 
  4. Turn AutoSync back on 

2. AutoSync or Manual batches are occurring too often for the amount of invoices waiting to be batched. 

Cause: Auto sync is not finished batching the first batch and starts a new batch.

    Resolution: 

  1. Wait until all batches complete or fail
  2. Run a manual sync (optional)
  3. Set AutoSync time to the default 120 minutes

3. QuickBooks was unsuccessful in receiving access token

Cause: This can happen for a multitude of reasons.

    Resolution: 

  1. This is a known issue at this time  
  2. This can cause AutoSync to disconnect.
  3. Verify AutoSync is still enabled. 

4. Batch is too large

Cause: The batch is greater than 100 invoices, expenses, purchase orders, or payments

    Resolution: 

  1. AutoSync will break this into multiple batches of 100   
  2. Please try submitting a smaller batch if a manual batch is needed.

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