Encountered ConnectWise API Error: 400: payment object is invalid

Error

Encountered ConnectWise API Error: 400: payment object is invalid

Cause

This error is given when payment method given is not accepted by ConnectWise PSA. ConnectWise only accepts payments and credit memos as acceptable payment methods

Examples

  • Negative down payment to offset the original down payment will not be accepted
  • Invoices with a negative value will not be accepted

Resolution

Please check the invoice being generated. Miscellaneous and down payment invoices will not be be able to be applied to an active invoice. Please generate a Special Invoice as a Credit Memo Type.

 

Error

Encountered ConnectWise API Error: 400: payment object is invalid. Only one payment application is allowed. Please edit the existing payment application.

Cause

We believe that the root cause of this error is that ConnectWise may not delete all payments from the invoice during the normal course of payment application.

Resolution

Please rerun the payment batch and verify the application was successful. If you continue to receive the error, please contact support with the Batch number in your browsers web address bar so our development team can review these logs


Please review the following articles on how Credit Memo's are handled.

  1. Handling of Payments and Credit Memos
  2. How do you handle syncing credit memos back into ConnectWise PSA

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