Encountered ConnectWise API Error: 400: payment object is invalid

Error

Encountered ConnectWise API Error: 400: payment object is invalid

Cause

This error is given when payment method given is not accepted by ConnectWise PSA. ConnectWise only accepts payments and credit memos as acceptable payment methods

Examples

  • Negative down payment to offset the original down payment will not be accepted
  • Invoices with a negative value will not be accepted

Resolution

Please check the invoice being generated. Miscellaneous and down payment invoices will not be be able to be applied to an active invoice. Please generate a Special Invoice as a Credit Memo Type.

 

Error

Encountered ConnectWise API Error: 400: payment object is invalid. Only one payment application is allowed. Please edit the existing payment application.

Cause

This error is given when there is more than one payment is applied to a invoice in a single transaction.

Examples

  • Invoice 25 received payment 25 and 26 in the same transaction

Resolution

Please check the invoice being flagged in QuickBooks Online. In the example given above, You would need to apply one payment to the invoice per transaction. 

  1. Example: Apply Payment 25 to invoice 25, save and close. Apply payment 26 to invoice 25, save and close 

Once corrected, please rerun the batch.


Please review the following articles on how Credit Memo's are handled.

  1. Handling of Payments and Credit Memos
  2. How do you handle syncing credit memos back into ConnectWise PSA

Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.