Error
The service revenue account was not specified. This typically means that the GL Account Setup Table in ConnectWise PSA is not properly configured. Please ensure that your GL Setup in ConnectWise PSA is correct for this mapping.
Cause
This means your GL Account is not set up correctly and the Account field is missing for the GL Account mentioned in the error. Here is an example of what that looks like. This field cannot be blank and will need to be filled in.
Example
Resolution
1. Open the invoice that is mentioned in error.
2. Navigate to the GL entries tab.
3. Click on the account mentioned in the error (i.e. accounts receivable account)
4. Most likely the Account field is blank. This is the root cause of the issue. Enter a name in the Account field and click save and close. Then you can batch the invoice again
How To find the GL entries
Expenses
1. Navigate to Finance > Accounting Interface > Unposted Expenses
2. Click on the credit account
3. Select the Type Names and edit the missing Account field in the GL entries page
Purchase Orders.
1. Navigate to Finance > Accounting Interface > Unposted Procurement
2. Click on the Amount
3. Click on GL description and fill out the missing Account Field on the GL entries page.
The “Account” field on the System > Setup Tables > GL Accounts table in ConnectWise PSA must be consistent with the “Name” field on the Company > Chart of Accounts > Account screen in QuickBooks Online.
Note: the fields are case-sensitive and values should match exactly.
Note: Items will not be automatically created in QuickBooks Online if their GL Accounts are not found in the QuickBooks Online Chart of Accounts. An error message will be raised when attempting to push transactions.
It is important to note that any time that you make changes to your GL Account Mapping you need to open and then close any closed invoices that use that mapping for it to change. Once you have done that you can then successfully run the batch in QuickBooks Online to show the new account.